URL in Front Matter Overwritten with localhost

Hi, I’m new to Hugo, so sorry if this is obvious.
I set video=“https://youtu.be/dQw4w9WgXcQ” in one of my posts, post.md

I setup the default post list template with this block:
{{ if isset .Params “video” }}

<!--                       <iframe width="560" height="315" src="https://www.youtube.com/embed/gd5yB9Vmd6I" frameborder="0" allow="autoplay; encrypted-media" allowfullscreen></iframe>
 -->                    </div>

When I run it using hugo serve, it gives a 404 error, since it appends the http: / / localhost/1313 to the url. Is there a way to disable that? Does it only do that when run locally?

I’ve never had this issue. The URL should be fine when you publish your site.

Yep, turns out a file version issue was the culprit. Thanks!