HUGO

Unable to deploy - can't figure out what I'm doing incorrectly

I’m fairly new to deploying a web app but fairly well versed with Hugo. I’m using the theme “Introduction” found here: https://github.com/victoriadrake/hugo-theme-introduction and I feel as if I’ve followed every instruction that I can find in their logs. However, when I deploy on Netlify, I’m greeted with this error:
3:04:12 PM: Building sites … ERROR 2020/11/29 20:04:12 error: failed to transform resource: POSTCSS: failed to transform "css/main.css" (text/css): PostCSS not found; install with "npm install postcss-cli". See https://gohugo.io/hugo-pipes/postcss/

I have installed dependencies both globally and into the project. Is it that I’m missing a config line or… not entirely sure. Any help is greatly appreciated!

npm install postcss postcss-cli

You need both.

Hi @jmooring ! I have installed both dependencies, and I can see them in my list of dependencies. Still getting the same result. Any idea?

Have a look at this:
https://community.netlify.com/t/instructions-on-postcss-and-hugo-should-i-commit-package-lock-json/7513

1 Like

That worked I think! Looks like the site is building and it lead me to running npm init which I goofily forgot. Thank you so much! @jmooring :slight_smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.