Trying to have a * in a taxonomy.category name?

Hello, I’m trying to have a * in my category name. I want it to be “*nix”. Unfortunately when I list out my categories the asterisk is getting removed and only “nix” is returned.

The default is to make it “url-friendly”. In 0.15 there is a preserveTaxonomyNames flag that will help you, in the future we may rethink this and give more options.

1 Like

Is there a way for me to keep “nix” as the url-friendly part but apply my own custom label?

Sorry, I was too fast.

The preserveTaxonomyNames=true will still make the URLs “correct” (in this case, remove the asterisk), but it will be kept “as typed” for all the other usage.

preserveTaxonomyNames is default false as it is a breaking change to turn it on by default. It means that Foo and FOO are two different taxonomy values. But if you are aware of that it should be better.

Thank you!