Translate

hi,

i wish translate juste one section name but i not want create a translate configuration for my al website.

:wink:

You need to show what you’ve done, so we may advise.

Have you tried the example described at https://gohugo.io/content-management/multilingual/#translation-of-strings ?

hi @maiki

yes i create i18n folder and i add fr.toml

[authors]

other = “Auteurs”

my url is mywebsite.com/authors/roger/ (it’s all rogers 's articles )
But my Url was not change i wish have
mywebsite.com/auteurs/roger/

I might not be understanding correctly, but if you simply want one section to appear under a translated URL, you could simply use an alias in the front matter for the “translated” URL. Ex:

If http://mywebsite.com/authors/roger/ is the URL that hugo automatically assigns,

then in the front matter for the list page of that section, simply add something like:

aliases = ["/auteurs/roger/"]

and that should work.

hi @angus,

your are understanding :slight_smile:
but if i use aliases in roger.md frontmatter this solution don’t work i don’t know why :frowning: .

if i uses url: "auteurs/roger/ it work but my page work with authors & work with auteurs it’s duplicate no ?

Setting alias command in the front matter should work, but I’ll admit I’ve never had need to use it. Did you check the actual html file that hugo creates to do the redirect and see what it says and why it’s not working.

If you use url in the front matter, then that will override the default URL that hugo would use, and that would be the only URL that could access that page.

@FR-Coco, I can’t reproduce your error, so unless you share a Hugo project, we can not assist you.

You keep asking all these little questions, but if you share your repo then we can see what’s happening and understand a lot faster.