Theme rendering doesn't go as expected

Hi everybody,

I have a little problem with my template, when i run my hugo server on my raspberry pi 4 (raspbian / armv7l) i don’t have the same template as the original. but when i run hugo server on my windows machine it goes well.

I will show you with screens attach to this post the difference between my theme and the original theme.

I’m using Nix theme. I installed latest version (v0.80.0) of gohugo with binary and dpkg on my raspberry pi. Then, I cloned theme with git clone into themes repository. I correctly completed the config.toml and ran the server with hugo server --bind=“” .

Finally i got the wrong theme page on my raspberry server.

Someone have an idea about what’s going wrong ?

You forgot to add your screenshots. It’s not quite clear what exactly is your problem. It is probably best if you would put a repository online somewhere so we can have a look at it.

1 Like

You’re totally true, il will link images to this post! It will not be hard for you to determine which one is going wrong

i found what’s going wrong on my webservice. I should have check for this at the first time but I didn’t…

It seems that the css page “nix.css” cannot be accessed when page is loading “GET http://localhost:1313/css/nix.css net::ERR_BLOCKED_BY_CLIENT”

I don’t know why it is happenning, but i wanted to inform people that have the same problem

BLOCKED_BY_CLIENT means your web browser did not load it. Typically you should find a longer explanation in the browser console. It might be something CSP related or a security setting or even a browser plugin that blocks this file.

I finally found where it came from.

At the beggiging, when i cloned the template, i wrote the theme and the baseURL into config.toml. But the problem was that baseURL wasn’t considered and when html page was created it replaced the href to nix.css by locahost:1313/css/nix.css.
Then, when i was trying to access the website from another machine than the host one it was trying to reach localhost:1313/css/nix.css.
Obviously, it couldn’t load the css page as this file couldn’t be on client machine.

In the end, to have the right baseURL i started the server with —baseURL (-b) parameter like this : hugo server —bind=“” -b “http://XX.XX.XX.XX
with XX.XX.XX.XX as my machine ip hosting the hugo server on my network.