[Solved] Markdown not working as expected

I did some changes to the “minimal” theme, like switching to Bulma instead of using Bootstrap.

But now, when I look at the posts, not everything work as expected.
Specifically, when I click a post, I can’t see the markdown heading being bigger (to me it looks like a standard <p></p> paragraph).
Or when I space out between a sentence and an other, it does not reflect in the final post.

I looked at list-item, lists, all the layout pages, but nothing seems problematic to me.

Repo -> There you go.

Bulma and Bootstrap use different classes. Did you go through your templates and replace everything as appropriate? Also, at least the first time I used it, Bulma did not have any javascript included by default like Bootstrap does.

Yes, I did, that’s why I can’t understand why it doesn’t work.

The javascript file is just there because it is used by default by the “minimal” theme, but I have removed the connections between javascript and the other files.

If you look at the rendered page, then inspect the styles applied to your h4 element, you will notice that bulma.min.css applies the following style:

h1, h2, h3, h4, h5, h6 {
    font-size: 100%;
    font-weight: 400;
}

… which makes it look like the plain paragraph style.

You need to use the content class to enclose your content so bulma styles h* tags appropriately. Bulma docs here: Content | Bulma: Free, open source, and modern CSS framework based on Flexbox

It is not a markdown or Hugo issue.

I’m not sure what this means. Can you give an example?

If I write down a sentence and then leave a blank line and then on a third line I write something I should see a blank line between the first and the third one:

Hi how you doin

Alright fine

Instead what happens:

Hi how you doin
Alright fine

No matter how many blank lines I sneak between two sentences.
The blank lines are not considered at all.

Markdown processors do that. Try two spaces on the blank line. If § is a space, do like:

Hi how are you doing
§§
Alright fine

You can control “blackfriday” markdown processor settings in your config.toml.

Markdown processors do that. Try two spaces on the blank line.

I’m not convinced. I said I can add as many lines as I want but no blank line will be there.
And I don’t think it’s something linked to the processor. If I use the original “minimal” theme that doesn’t happen.

I’ve tried what you suggest, but it just prints out §§ in that line where it is inserted as any other letter:

hi how you doin
§§
alright fine

prints out as ->

hi how you doin §§ alright fine

both in the original “minimal” theme and the one that I have made.

Sorry I did not explain well; where the § is put a space.

see also: https://gohugo.io/content-management/formats/#configure-blackfriday-markdown-rendering

Alright!

I just needed to encapsulate {{ .Content }} inside a content class.

Now everythings works as expected including blank lines.

Thanks @pointyfar