[SOLVED] Host on GitLab: not able to see the output

I have made a test with GitLab, reading this guide.

The gitlab pipeline seems to work but I have 404 error the URL https://aborruso.gitlab.io/margieepallino/ .

The repo is this https://gitlab.com/aborruso/margieepallino/tree/master.

What’s wrong in my repo/procedure?

Thank you

Hi aborruso, it seems you’re facing the same problem i posted about few weeks ago: [SOLVED] Hugo on GitLab Pages showing 404 error

As reported on that post, I got it solved by adding a before_script section to .gitlab-ci.yml like this:

  • git submodule init
  • git submodule update --force



1 Like

Thank you @up4digital it works.

But why the code below is not in the documentation?

  - git submodule init
  - git submodule update --force

A stupid question: where are the produced static files of the public folder? Is there an hidden branch?

Thank you

I have created a related pull request https://github.com/gohugoio/hugoDocs/pull/160

Now @up4digital your solution is in the documentation: thank you again !

Well done Andrea !

1 Like