[SOLVED] Error: cannot unmarshal !str `en-us.yaml` into []map[string]interface {}

hello everyone!
i’m new to hugo but very excited!
And my excitement just got massive test. i just got an error:
C:\Hugo\Sites\bibl.bi>hugo -v server
INFO: 2016/12/11 22:02:38 hugo.go:405: Using config file: C:\Hugo\Sites\bibl.bi\config.toml
INFO: 2016/12/11 22:02:38 hugo.go:517: using a UnionFS for static directory comprised of:
INFO: 2016/12/11 22:02:38 hugo.go:518: Base: C:\Hugo\Sites\bibl.bi\themes\hugo-tranquilpeak-theme\static
INFO: 2016/12/11 22:02:38 hugo.go:519: Overlay: C:\Hugo\Sites\bibl.bi\static
INFO: 2016/12/11 22:02:38 hugo.go:551: syncing static files to C:\Hugo\Sites\bibl.bi
Started building sites …
Error: Error building site: yaml: unmarshal errors:
line 1: cannot unmarshal !!str en-us.yaml into []map[string]interface {}
I’m using Windows 8.1, official git client from git-scm.com, theme git’ed, everything is just like manuals direct.
i suppose it’s line break type issue, and i tried different options in git with no luck.
May some kind person point me a way, please?

We’re going to need to see the contents of en-us.yaml. If can cut it down the smallest size possible that still triggers the error, that would help.

Strange that you both appear toml and yaml. It is more logical to choose one format and use it in all the configuration files.

I believe go-i18n requires YAML input files.

Thanks for you answers!

I worked in debian and everything worked just like in manuals - hugo is very promising for me.
Now i get back in Windows and started to bagtracking it all.
The theme i get troubles in is Tranquilpeak. Awesome theme. It supports i18n and first i use its examplesite with config.toml and make changes in config.toml:

baseurl = "kilmezlib.ru"
languageCode = "ru"
defaultContentLanguage = "ru"

And i get:

Error: Error building site: yaml: unmarshal errors:
  line 1: cannot unmarshal !!str `en-us.yaml` into []map[string]interface {}

When i remove \themes\hugo-tranquilpeak-theme\i18n\en.yaml completely, i get two screens of errors, but hugo starts and site works. That’s why i believe than reason of initial error message was in content of en.yaml:


and that’s all. It’s not a YAML, actually. And hugo can’t unmarshal it. If i copy content en-us.yaml in en.yaml - hugo starts (with a lot of errors, actually, but for now i believe they are theme-related)

Again, everyone - THANK YOU!
i think we should call the topic resolved

/me whispers: but i worked like breeze in debian… why?..

en.yaml looks like it’s a symlink to en-us.yaml, which could be causing an issue in Windows.

absolutely right: