[SOLVED] Build not including content folder

I am using the Initio template with the sample config file unchanged.

When I run build, it does not include anything in the content folder, and the Blog link goes to a 404 page.

Hi - looks like that theme was not updated recently but, hugo has been updated, so I think the theme needs to be refreshed to match how hugo works now. You might contact the theme author?

Edit: sometimes it’s true that themes need to be updated but, in this case it was about not toggling draft in frontmatter.

I tested this on two computer (windows and mac) with multiple themes. It seems like I can see my posts when I run > hugo server -D

However, when I build them, I do not see a /content folder inside the /public folder.

I figured it out. It was a stupid mistake. I did not remove draft: true from the content pages.

Ok, glad you worked it out.

Neither the content folder nor the static folder will be visible in the published site. Those are source folders which hugo will use as input to generate the site.