[SOLVED] '404 not found' - basurl

hi hugoistas , newbie here…

sometimes running ‘hugo serve’ in my laptop stays ‘like Web Server is available at //localhost:36609// (bind address’ instead of the expected “Web Server is available at http://localhost:36609// (bind address”, (note the ‘http’ missing… ), thus leading to a ‘404 page not found’. What are we missing here ?

running hugo v0.88.1-5BC54738+extended and disabled https forcing in the browser, just in case …


For the record,


baseURL: “https://” …
okey gonna put

baseURL: “” ,

Fixed, OK now

It’s not 100% clear what your problem is but baseURL is only relevant on a live deployment of your GoHugo website. On the local development server it is ignored and your local IP and 1313 as port is used. If that port is not available another port is used. If you have a broken Hugo server running it could be that the port is in use and thus not available. But your initial post above cites twice 36609 as port, so you either have an error in your error description or a specific setup that would require you to post your setup for anyone to help.

Good though that you solved your issue or that it’s not recurring anymore.