Slug in multilingual site not working as expected

Hi all!

I ran ran into a strange issue:

Following Régis’s instructions

config.yml is

    languageName: English
    weight: 1
    languageName: Français
    weight: 2
    languageName: Spanish
    weight: 3

The folder structure is

    └── about
        ├── header.jpg

Yet, when front matter for is

title: À Propos
slug: a-propos

the path is not /fr/a-propos/index.html as expected but strangely /fr/about/a-propos/index.html.

(I also tried to change the filename to

Has anyone got a clue what can be wrong here?

How is the permalinks setting in your config set? For example:

  posts = "/:year/:month/:day/:slug/"

Thank you, Rick!

The config is just as shown above. I have set up a new minimal test setup with just the config.yml and the three files in /content/about/.

(BTW: I have some large multilingual Hugo sites running, yet with a different folder/content structure and without page resources:

content     └──
    └── └──

There slug: works as expected.)

I did a lot of testing now. No success.

Now, I clonded Régis’s website and added slug: test to this page

The English (standard language) URL is


whereas the URL for Frech is now


(expected: http://localhost:1313/fr/project/test/).

Did I just get anything wrong? Is this the expected behaviour? There are no frontmatter: oder permalink: setting in Régis’s brilliant article.

I do not want to ping/disturb Régis :wink: