Problems with my first site


#1

Hello, I’ve just installed gohugo along with the angels-ladder theme. I’ve tried adding a couple of markdown pages, when I run localhost:1313 all I see is the title as shown:

What am I forgetting to do? Thanks!


#2

Do you have edited content?


#3

Posting the source of your site too so that people can debug :wink:

See Requesting Help.


#4

I think so. I ran hugo new posts/my-first-post.md and hugo new posts/my-second-post.md. I then manually edited content/posts/my-first-post.md and put a line of plain text in there. I was expecting, perhaps foolishly, that the hugo app would automatically list the post entries in the site’s home page.


#5

The source on gitlab, such as it is, is: https://gitlab.com/carlca/hugosite.


#6

Your site requires logging into gitlab.com to view. Please make it publicly visible.

Also, Hugo doesn’t “automatically list the post entries”. It parses templates, which is what your theme is, a collection of templates. Every single theme is different, so you can also ask the theme author for assistance, as they created your templates, and will probably have included details for getting content to show up.


#7

“Your site requires logging into gitlab.com to view. Please make it publicly visible.”

Should be publicly visible now.

“Also, Hugo doesn’t “automatically list the post entries”. It parses templates, which is what your theme is, a collection of templates. Every single theme is different, so you can also ask the theme author for assistance, as they created your templates, and will probably have included details for getting content to show up.”

Ah! I think I have misunderstood how the themes work. I shall investigate the accompanying docs a bit more thoroughly. Thanks.


#8

I can’t see a code repo: https://gitlab.com/carlca/hugosite

Please refer to the GitLab docs on permissions for projects.


#9

Try it now…


#10

Your posts are set as drafts. From the front matter doc:

draft
if true, the content will not be rendered unless the --buildDrafts flag is passed to the hugo command.


#11

Thanks again. It seems this package is not quite as “out of the box” as I thought it was! No matter, I will resolve to RFTM much more!!


#12

Looking at the theme, it seems to work as advertised. But Hugo won’t render posts that are marked as draft, unless the flag is passed at build time.

At any rate, good luck. :slight_smile:


#13

I’m just in the process of changing the draft settings as we speak. Thanks for your time and patience and apologies for my noobieness!


#14

Seems there were problems with the original theme. I’ve just switched to a theme called “kiss” which is maintained by a guy who forked it from the maintainer of the original theme who has apparently abandoned his work.

The new theme works just great. It’s very minimalist but I like that. And it shows up the pages!!

My next problem is trying to get gitlabs to host and display my site…


#15

So, I can see that my hugo site is sucessfully uploaded to gitlab but if I try to view the output pages at https://carlca.gitlab.io/hugosite/ I just get a 404, while if I try to view the pipeline stuff being built, https://gitlab.com/carlca/hugosite/pipelines and then press “Get started with Pipelines” I’m greated by a page so dense with information, it’s more likely to finish me off rather than get me started!

Which “glaringly obvious” part of the documentation have I contrived to miss this time?

And what’s this utter nonsense with “New users are only allowed to post a maximum of 2 links”?


#16

First, please review the notes on requesting help:

To assist with finding information, we break problems down into smaller bits, so if your posts are showing up as expected, please mark this topic as solved; it will help folks searching in the future.

Then, if you have another question, please start a new topic. However! Before you jump on that, please search our forums for tips on hosting with GitLab. It is a common use case, and many folks have discussed and solved issues around it.

Finally, the 2 link limit is to prevent spammers from creating accounts and posting a bunch of links. Using the forums for a couple of days will remove those limitations. :slight_smile:


#17

I have done the necessary due dilligence. There are countless unresolved issues on the web relating to failure when deploying Hugo apps to Gitlab. Enough to indicate that it is not a simple case of clueless newbies not R(ing)TFM, but a more fundamental systematic problem with the systems and documentation currently in place.

And just now I tried to start a new topic. I limited my link quotient to 2 links, and this forum software had the cheek to say that I could not post a message with that link (both of the links were Gitlab links).

Now I see that a message of mine was hidden by @bep for being spam! WTF! Explain yourself @bep!


#19

I am not patronizing, okay. You seem distressed, and I want to create a calm space to discuss this. We can leave Bjørn out of this, that is just the spam system doing the best it can, and it just so happens that spammers often link to the same site over and over again.

We have no hard feelings, this is a technical issue, okay?

You are struggling with our forums, and that is a bummer, but we are gonna need to get past that to help you with your issues. If you want to try to create a new post asking about the specific issues you are having in GitLab, please do. Just avoid links for now. Explain the error message or step in the process you are having difficulty with, and someone will discuss it with you.

Please keep in mind that all of us are here voluntarily, so it is best to keep it light in discussion. :slight_smile:


#21

I would point out in my defense that it is very annoying to be presented with messages such as this:

30


#22

@maiki Any thoughts about the 240-hour message I mentioned?

As it turned out, I think this was a false alarm, but messages like that do nothing to foster the calm space that you, so correctly, want to see. Is it any wonder I seemed distressed?

Anyhow things have moved on. I am now using the Icarus theme which looks really good, and I’m hosting with Netlify, who are really good and have a really calm and civilised support space.

I’ve abandoned Gitlab as well and switched to Github where things just work. As I mentioned before there are countless unresolved Gitlab + Hugo issues on the web, surely indicating some fundamental issues with Gitlab.

I’m having issues with the Netlify version of the site displaying differently from the same site but accessed via my custom domain, and only in Firefox Quantum. It’s very strange. I’ve raised issues on the Firefox forums. I can provide more info if anyone is interested in helping (hint, hint…)!

Correction. This last issue has been solved by the amazing Jessica at Netlify who suggested changing the baseurl setting in my config.toml simply to "/". This has sorted out the fonts so that various social network symbols like the Twitter bird all displayed correctly. This was due to domain conflicts and CORS issues. More here https://developer.mozilla.org/en-US/docs/Web/HTTP/CORS.

So, everything is good now, I just need to write some decent content, but that can wait for another day!