Posts not showing in Windows but showing in Ubuntu (hugo server)

Hi there. I have a weird problem. I was developing my blog with Ubuntu. And everything was working fine. Recently I wanted to write content from my windows machine as well. But no luck my posts are not being rendered by hugo. Here is my blog source code:

when I run hugo server this is my output on windows:

Building sites … 
                   | EN
+------------------+----+
  Pages            | 17  
  Paginator pages  |  0
  Non-page files   | 29
  Static files     | 14  
  Processed images |  0
  Aliases          |  0
  Sitemaps         |  1
  Cleaned          |  0

Total in 139 ms
Watching for changes in C:\Users\osman.cakir\Documents\osmancakirio\osmancakirioblog\osmancakirioblog\{content,static,themes}
Watching for config changes in C:\Users\osman.cakir\Documents\osmancakirio\osmancakirioblog\osmancakirioblog\config.toml
Serving pages from memory
Running in Fast Render Mode. For full rebuilds on change: hugo server --disableFastRender
Web Server is available at http://localhost:1313/ (bind address 127.0.0.1)
Press Ctrl+C to stop


drafts is not a problem. all my posts have draft:false attribute.

Have no idea what is causing this. If you need more info please let me know.

Be careful using .File.Dir, because it depends on OS environment. (UNIX vs Windows)

in UNIX File.Dir will produce /notebooks/,
in Windows File.Dir will produce \notebooks\

using simple replace will do the job,

1 Like

what’s your command on Windows?
use the options --watch --noHTTPCache

thank you so much. that change did the trick!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.