On version >= 0.19: permalinks (set by url via front matter) go to 404 page

Initial setup was using 0.18.1. I want to update the site using different machine (version 0.19 is installed). I found out my permalinks (that were imported from wordpress) are broken. These posts have url set in the front matter. The post that doesn’t have url works fine.

I checked the documentation that it is still possible to override the permalink by setting the url via the front matter. So I don’t know what went wrong. Did I miss something? On the list page, the permalinks are rendered correctly, they’re just all go to 404 page.

Tried upgrading up to 0.25, still the same. It only works on 0.18.1. Upgrading the theme (Cactus) doesn’t help either. Appreciate your help. Thanks.

As this is likely a configuration issue, you’ll need to share the site’s code to debug.

Yes. I found this post which explains exactly my problem. The wordpress importer added layout front matter. So I remove the line and it works. Thanks @maiki.