No Images or posts when built on Amplify vs Local

Hey all,

When I am testing my site locally, I can see all my posts and images but when I try to use the automated build script via Amplify, I am just seeing the landing page but no content (posts, images, etc…)

I don’t quite understand the magic that is happening with Amplify and so I am guessing the issue may be with the build script. I already set it to use the latest tag for Hugo.

version: 1
    # IMPORTANT - Please verify your build commands
        - hugo
    # IMPORTANT - Please verify your build output directory
    baseDirectory: /public
      - '**/*'
    paths: []

Is the base build script … I’m not quite sure if I need to change /public as the baseDirectory or something. Any assistance would be great!

Here is my Repo

Please don’t judge me, I’m still learning lol

I had everything marked as draft and was running hugo server -D because that’s what most of the tutorials were showing. Just being an noob overhere.

Well… I’m still not seeing images. Repo is still correct but I am working off of the branch fixing_build_pipe I tried moving them into the same location as the page kind of how I saw it was done for the theme I am using. But it’s still not showing up, sadly :frowning:

What is Amplify?

It’s the AWS service that builds and helps host - kind of like Netlify

If you make a change to the home page, can you see it deployed?