New Session cannot create pages after hardware restart

Hey guys and gals, So im pretty new to hugo, and ive created a simple site, after i log off or turn off my system im unable to get hugo to see that i have a working site directory, instead when i want to create a new page with the templated information it tells me i need to create a site in order to do that action, But im already in the directory. How do you go about going from one project to another, surely there is a way to redo this with out having to create a new site every time i want to work on my pages? Thanks for your help in advanced, i looking forward to your response!

Also is there a discord for this community or is this just the only place to get assistance or to speak / collaborate with other users of hugo?

Kind regards

This is the official support forum for Hugo.

Have you read the Quick Start Guide?

If you haven’t please check it out.

Hugo is not a process that autostarts after a system boots up, you need to execute the hugo or hugo server commands in a terminal from a directory that has the structure that Hugo expects for website to be generated.

Yes i have read the basics, its just not clear exactly (at least not immediately clear to me) how to resume. when ever i run the commands it tells me i dont have anything and im like sitting in the directory inside of console where the site is, hugo just wont see it and asks me if i want to make a new site

The error is specifically this:

Error: Unable to locate config file or config directory. Perhaps you need to create a new site.

What OS are you using? Have you opened the console in the project directory?

on my linux machine it works fine, i just navigate tyo the directory in console and type hugo, and it reads it. on this windows machine it wont work with that method for some reason. so im a little unsure. ive tried through cmd and powershell with no luck, i installed hugo through choco as i have used that for many years now. i can see the config toml in the directory, could that be the issue?

Typically one changes a directory in Windows with the cd command.

In any case I stopped using Windows a number of years ago and I am not familiar with choco.

Perhaps another Windows user can help.

Thank you for your time and effort, i hope they can. This is my first return back to windows after 20 years of linux and im not having any fun lol. its all very different. work flow is messed up which is worst haha. any way thanks for your help

On Windows 11, I just performed a clean installation of Chocolately, then used Chocolately to install Hugo (extended). I am unable to reproduce the problem you reported.

I followed these instructions to “Install Chocolatey for Individual Use”

I followed these instructions to install Hugo (extended) with Chocolately:

I log out, log in, cd back into the project directory, and run hugo. Just make sure you are in the root of your project directory when you run hugo.

Thanks @jmooring that has solved the issue, i reinstalled and installed the extended edition and it works perfectly now ! thank you ! i was not using the extended edition so maybe it was either an issue with the choco install not right for some reason or the extended edition is the key to use in windows 11. but it works now after i followed that process. thank you!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.