Hugo

New post is not visible

config.toml : https://gitlab.com/leela52452/hugo/blob/master/config.toml

issue page https://leela52452.gitlab.io/hugo/

uploaded who am i file in content/english
there is no trace of post on homepage and all posts.

what am i doing wrong

As per your recent commit it seems that you have not entered any front matter.

Front Matter is required in content files.

i have added front matter, but it has no effect :wink:

According to line 14 of your project’s config, you have set the content directory used by Hugo to:
contentDir = "content/english"

There is no such folder under content in your project. Hence no post is rendered.

moving content directory from root to themes directory resolved the issue.

lesson learnt content belongs in theme directory

No. That is not the correct approach. The theme directory is not meant for content.

Please have a look at the various configuration settings for an explanation of what contentDir stands for.

1 Like

perhaps my issue is related to https://github.com/gohugoio/hugo/issues/5662

No it is not related to that issue.

Simply remove the contentDir parameter from the config.

excuse, however it seems to be correct, https://gohugo.io/content-management/multilingual/#translation-by-content-directory

You are posting all sorts of random links here and I am afraid that I do not have further time for this support ticket.

As I said above you need to delete line 14 from your config.

Then execute hugo server and visit localhost:1313/hugo/

You will see that the missing posts will be rendered.

They are missing now because there is no /content/english directory in your project and therefore Hugo cannot find the content which is directly under /content/

Please have a look at the Quick Start Guide to familiarize yourself with the basics.