I get invalid date when I post the site on AWS

I have a site that is hosted on AWS EC3. when I run it locally using hugo , the date data from the individual posts gets rendered just fine. When I post it on AWS the dates get rendered as INVALID DATE. And I have no idea why.

I’m using the bilberry-hugo-theme. the oddity is that it works locally (http://localhost:1313) and not on AWS, yet its the same files.

I must be missing something. The source is at https://gitlab.com/rabosaur/twopools.git

Please do not use Upper Case when typing words in the topic title.

To get some help for your issue with dates, you most likely need to share a link with the source of your Hugo project.

ok - https://gitlab.com/rabosaur/twopools.git

I’m publishing to AWS without trouble, using this date format:

date: 2018-05-06T07:07:27+09:00

If S3 is replacing your date with “INVALID DATE” (in the source?) then I’d say you should look into changing the date format to something it can accept?

it works fine when running locally (http://localhost:1313), the same dates convert to INVALID DATE when deployed to AWS. I’ve tried several variations on the formatting with the exact same results. I’ve used both yyyy-mm-ddThh:mm:ss and yyyy-mm-dd formats, with exactly the same results.

I see the date variations you tried in your repo but, I don’t know about what AWS is expecting. Could it be the method you’re transferring the files by?

I’m transferring via this utility: https://github.com/bep/s3deploy

I use “aws s3 sync” , there really isn’t any reason that shouldn’t work. Remember it works fine locally. AWS isn’t doing any compute cycles on this, its all local (that’s how static sites work). So, something really weird is going on. I’d really rather have it just string copy the datestamp in the .md file and not post process it. But its probably sorting the posts on that field. I didn’t want to have to change the template, but if I have to so be it. So far, I’ve not received any answers from the template author.

I’m going to try manually copying the files up using drag and drop.

hmmm. that worked. ok, maybe I can’t just ftp the files using aws cli tools. this makes no sense. anyway, maybe its not hugo’s issue. thanks!