Hugo Site Isn't Recognized by GithubPages

Hi All,

I’m new to Hugo after a switch from Mac to Windows killed my ability to use Jekyll with any consistency.

Anyhow, I built a site and pushed it to Github. The whole site appears to be there, no issues. When I run it locally, it works perfect.

However, the only thing github pages will output when I go to the site’s URL is the

Repository is here:

Can anyone help me figure out what I’m missing?

Thank you!

You have to tell Github Pages not to generate a Jekyll site, then publish your Hugo output folder into your gh-pages branch. I imagine you can google for some instructions on this. Alternatively, Netlify has a free tier and it’s good alternative.


I ended up setting my publishDir to /docs and deploying that way.

I got everything working, that is until I tried to set it up with a custom domain. Now i’m having DNS issues.

I never remember Jekyll being this hard to deploy!

Github pages was built for Jekyll. You’re swimming upstream using any other generator with it. It doesn’t have https either, unless you use something like Cloudflare. I’ll reiterate my earlier suggestion of using Netlify.

1 Like

I took your advice :slight_smile: site now works perfectly using Netlify!

1 Like