Hugo not creating html files

I’m trying to get hugo working with github pages and it feels like I’m so close.

Currently when I run hugo locally, my public directory (which is in my .gitignore) is created successfully and served up if I run hugo’s server.

I’m now trying to use wercker to automate things, as I’m going to hand the site over to someone else to create and edit the md files for content.

When the automation runs, I’m only seeing md and xml files present. One of the staff at wercker tried out my build and is not seeing the public directory being populated with html files when running it locally, so I’m missing something (or have added something) somewhere that’s breaking things.

My source directory is


Ok, sorry, my bad.

While the theme had been added as a submodule, I thought I’d removed all traces of that so I could amend it as I see fit, however it appears that the code hadn’t hit the repo properly.

I’ve now deleted the theme fully, including its submodule reference and it’s working fine.