Hugo

Hugo 0.56.0 and page resource issue

Thanks for the updates. As always, I appreciate your efforts.

I have not been able to confirm it yet, but it looks like this update broke my page resources. I am only using two instances on my site and they are both broken.

I am in the process of rolling back to confirm this is the issue. Anyone else having this issue?

Jeff

Hi @jkinley. Moved your post to a topic of its own. Feel free to adjust title.

Also see: Hugo 56, can't evaluate field Fill in type resource.Resource

Zach,

You rock! My bad for not posting in the right place. I am under deadline and I just noticed this problem.

I don’t think I have time to wait for a fix on this. I started looking for how to roll back with homebrew and nothing is working. Any ideas?

Thanks,

Jeff

I don’t know if homebrew supports installing previous versions of hugo (someone correct me if I’m wrong).

You can always download the executable manually then add it to your PATH. See: Friendly reminder, you don't have to wait on a package manager then edit the download URL to be the hugo version you want.

1 Like

Zach, I have successfully rolled back and it resolved the issues. Thanks again for your support.

Also, homebrew does support this. I found the solution in here:

32%20PM

Jeff

Is anybody else still having issue with page resources? We have updated to the latest and there still seems to be an issue.

Thanks,

Jeff

I’m actually experiencing problems with accessing page resources from headless bundles.

My headless leaf bundle structure looks like this:
grafik

Accessing the page resources of that headless bundle via (.Site.GetPage "domains").Resources.ByType "page" works in 0.55.6 but not in 0.56.x anymore.

There the (.Site.GetPage "domains").Resources only contain the logo.svg files but not the page resources.

Anyone got an idea why that is?