How to turn off escaping letters when using Goldmark

There is a lot of math in my posts. In LaTeX, I break the lines using ‘\’. However when I generate the html files using hugo, it is translated into ‘’, making further rendering by MathJax unavailable.
A possible solution to this is to use ‘\\’ instead of ‘\’. But I want my markdown files to be consistent with my original ones. In fact ‘\’ works fine for vscode preview, I don’t want to ‘translate’ my posts before I publish them using Hugo.
So is there any way to turn off such escaping ?

No, there is not.

Did you try Pandoc instead of Goldmark?