How can I change the default language in Educenter?

I’m working on a project with Hugo and Educenter theme, that come multilinguas, with english as default and french as second language. Moreover I traslated it in italian, I swich off French language, but I can’t get italian to be the default language. I tried to change in config.toml the language weight to 1 for italian and to 2 for english, but it just affect the drop-down menù to choose the language. I also tried to change the Baseurl to www… in Exemplesite config.toml and netlify.toml, but nothing, while if I change the Baseurl in the netlify.toml at main directory, I get the english version as well, without css.
Is there a way, please, to get italian language as default in Educenter Theme?

You most likely need to change the language configuration order in the project config.

Have a look at the theme’s example site config.

I already tried as you can see here:

But nothing changed as here:

Maybe it depends on netlify settings?

I think you might get better help at the theme developers issue tracker. From what I can see in your samples it should work. Maybe there is a deeper issue (like Netlify not getting proper updates or not using your configuration to create the site). But that needs some deep dives into logs and code. Can you share your deployment logs from netlify? They might have indicators as to what is going on.

PS: put en into the disabled languages array and see what is happening. If it disappears and the site comes up in your language then go from there.


In your site configuration, in the root, set:

baseURL = ""
defaultContentLanguage = "it"

defaultContentLanguage sets the project’s default language. If not set, the default language will be en .

1 Like

Give thanks … now it works well!

Hey @DavideCalabria ,
Thanks for creating your website with my theme. Further if you have any issue I suggest you to post that issue in our github theme page as @davidsneighbour mentioned in the top.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.