Host on github not working

I’m trying to publish hugo content to github and tiried following the instructions at Host on GitHub | Hugo but it’s not working…

I’ve set up the repo such that master has the hugo site on it, then added the recommended github workflow file, then pushed. Github then runs the action without error, but when I try to visit the url it says it published to, I get a 404. I’ve tried setting gh pages source to master, root, docs, I even set up a gh-pages branch but nothing seems to work.

Is there something else I need to be doing?

Yes. Give us something to look at. What is the repository URL?

You are deploying to:

But your baseURL in _default/config.toml is:

And your baseURL in production/config.toml is:

OK I’ve updated those, but it still doesn’t work…

What does this page look like? Take a screenshot.

It should look like this:

Ah yes that was the last piece: Setting it to use gh-pages! Thanks!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.