Help with broken links

My project repository: GitHub - ProjectMountiainMan/HugoBrokenOnServer: This hugo project works fine when run with hugo -D server, but breaks when I actually try to host it somewhere.

My website works fine when I run hugo -D server, but not when I actually run hugo -D, and upload the public directory to an actual server. My project uses the Docsy theme.

I have tried editing the config file to enable ugly urls, relative urls, and changed the baseUrl. I have tried removing the backslash from my image links. I can get the docsy theme to load, and I can get the site to look great when tested from local host, but I can’t get images or links to work when actually deployed. The docsy theme only ever seems to work when I have baseUrl = “\”

Breaks how?
Can you point us to a live broken site?
Is this Hugo site a subsection of a parent site (e.g., https://some-construction-technology-company/docs)?

Also, it looks like you’re using an older version of the docsy theme, or you’ve modified it, or both.

I’m happy to point you to our site, but we would prefer a direct message instead of a forum post if possible.

Yes, it is a subsection of a parent site. Manually adding “…” enough times to the link address, using inspect element in the browser, will fix the problem. However, I want to configure Hugo correctly, and not manually do that to every image link.


I’m not sure if this site allows me to send the link to you directly, so I’ll just post it here and delete it later:

Also, the reply symbol at the top of my post sometimes appears and sometimes does not. When it didn’t appear, I tried deleting the post, and posting again, but I received an error stating that my post was too similar to what I had previously posted.