Gitlab doesn't build site anymore

Hi, I got my site https: // jenglert . gitlab . io hosted on Gitlab but I can’t get it to build anymore.

The last successful build was ~2 weeks ago, now whenever I try to push something to the repo and build the site Gitlab Pipelines throws the following error:

ERROR 2020/11/04 16:50:50 Failed to get JSON resource “https:/&api.instagram.com/oembed/?url=https://www.instagram.com/p/BGvuInzyFAe/&maxwidth=640&omitscript=true”: Failed to retrieve remote file: Bad Request

(I don’t use instagram API or embeds on my site fwiw, probably in the theme somewhere)

I encountered the same error when testing with hugo server locally (also ~2 weeks ago, never appeared before) but got rid of it using ignoreErrors = ["error-remote-getjson"]
See below:

Local machine:
Microsoft Windows [Version 10.0.18362.1139]
Hugo version:
Hugo Static Site Generator v0.77.0-EF290125 windows/amd64 BuildDate: 2020-10-30T10:13:29Z

Is there maybe an issue with the Gitlab Hugo version not being on .77 yet and not processing the ignoreError flag in the config.toml?

I don’t use Gitlab but there should be a way to specify the Hugo version used for site deployment.

Please search the Gitlab forums and Docs.

To host on Gitlab I only added a .gitlab-ci.yml to my Hugo site directory (https://gohugo.io/hosting-and-deployment/hosting-on-gitlab/#create-gitlab-ciyml). Is there maybe a way of setting the Hugo version here?

This is my file: https://gitlab.com/pauernet/hugo-seo/-/blob/master/.gitlab-ci.yml
last tested for 6 months :slight_smile:

All available Hugo versions on Gitlab are listed here: https://gitlab.com/pages/hugo/container_registry

By default you have, if I remember well: registry.gitlab.com/pages/hugo:latest

Now you can change the image parameter in gitlab-ci.yml to the Hugo version of your choice:

image: registry.gitlab.com/pages/hugo:0.78.1
1 Like

Fixed it thanks to https://github.com/Mitrichius/hugo-theme-anubis/issues/70#issuecomment-722902911 who pointed out that the Instagram shortcode was removed from the rich-content.md example in the Hugo exampleSite (see here). I had the file still in my content/posts directory and that broke the build. Removing the shortcode there as well fixed the build.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.