Generate single page rather than directory

How do I output single pages as html files rather than directories with an index.html?

For example,
I do not want: public/about/index.html
I would like: public/about.html

In your content, instead of




That’s exactly what I have, but when I generate the site and it gets published to public/ it becomes public/about/index.html rather than about.html

Ah, I misunderstood.

Perhaps what you want is ugly URLs.

When I try to run it, I get: “Error: unknown flag: --uglyURLs” and I don’t see it listed in the terminal help.

It seems to work as needed if I add it to the site config file, however.

Thanks for the help

Happy to hear that it worked in the config file.

I’m thinking that particular part of the docs is old. Because as you mentioned, running hugo help doesn’t list --uglyURLs as an option. Neither do the CLI docs.