Found no layout file for "HTML" error

I just installed Hugo on my machine (I use Linux Mint) and created a new website. Then I gave the hugo serve command and the following error appeared:
found no layout file for “HTML” for “section”: You should create a template file which matches Hugo Layouts Lookup Rules for this combination.
found no layout file for “HTML” for “section”: You should create a template file which matches Hugo Layouts Lookup Rules for this combination.
found no layout file for “HTML” for “taxonomyTerm”: You should create a template file which matches Hugo Layouts Lookup Rules for this combination.

How can I solve this problem? I installed the extended version of Hugo, I’m currently using v0.92.2

That depends on what the problem is.

You are more likely to receive a prompt and accurate response if you post a link to the public repository for your project.

See Requesting Help.

Let us see your code

Include a link to the source code repository of your project, because we really need the context of seeing your templates and partials to be able to help you. It is trivial to do a quick git clone on your repo, then run hugo server in your project, to help you out. On the other hand, recreating your code from screenshots, or sort of guessing at it, is not.

If you can’t share your repository for whatever reason, consider creating a dummy repo that you can share, which reproduces the problem you’re experiencing.

this is my repository that i made for test, i tried some themes and i got the same error

WARN 2024/01/10 19:50:40 found no layout file for “HTML” for kind “home”: You should create a template file which matches Hugo Layouts Lookup Rules for this combination.

WARN 2024/01/10 19:50:40 found no layout file for “HTML” for kind “taxonomy”: You should create a template file which matches Hugo Layouts Lookup Rules for this combination.

WARN 2024/01/10 19:50:40 found no layout file for “HTML” for kind “taxonomy”: You should create a template file which matches Hugo Layouts Lookup Rules for this combination.

Your test site:

  1. Does not specify the theme in the config file
  2. Does not have any content

If you’re new to Hugo, start with this:
https://gohugo.io/getting-started/quick-start/

And make sure you are using v0.112.0 or later, preferably the latest (v0.121.2).

1 Like

that’s true! I forgot the theme in config file…now its working

thank you!! :slight_smile:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.