Fill feature not available

I’m using Gitlab CI/CD to generate pages with hugo. I’ve used latest image to do it. But today when I’ve tried to build the pgae I got:

ERROR render of "section" failed: "/builds/strona2/cleanhugo_base/layouts/_default/list.html:25:22": execute of template failed: template: _default/list.html:25:22: executing "_default/list.html" at <.Fill>: error calling Fill: image "/builds/strona2/cleanhugo_base/content/blog/general_magic/cover.jpg": this feature is not available in your current Hugo version, see for more information

I’ve set the version to 0.117.0 ang got the same error. Interestingly on my local machine, with 0.117.0 it simply passed. Any ideas what can I try to fix it?

edit: just in case here’s my pipeline file:

  image: "${CI_TEMPLATE_REGISTRY_HOST}/pages/hugo:latest"


test:  # builds and tests your site
    - hugo

pages:  # a predefined job that builds your pages and saves them to the specified path.
    - hugo
      - public
  environment: production

Are you rendering the images to the WebP format?

what’s the best way to check it? Images on the rendered pages are jpg-s when I view on desktop, but at the same time I’ve noticed on the old ipad that in “mobile” mode images are not showing up in Safari.

Search your layouts for webp.

If that’s not something you can do, change your workflow file to use the hugo_extended image, and test again.

I found a couple of matches. Up until now it wasn’t a problem - why now it is (I’m just curious what’s the cause)?

I’ll try hugo extended image. Also went back to some old image on gitlab (didn’t know there’s extended version) and it generated page correctly.

The standard edition of Hugo cannot, and never could, encode to the WebP image format.

Perhaps your resources directory is under source control (then GitLab would use the cache), then you cleared it (then GitLab had to regenerate the images, but it can’t).

ok, that makes sense (just realized that previously I checked how the page looks locally and didn’t include some folders in .gitignore). Thank you!

The interesting bit is that with 0.82.1. image (not extended) I was able to generate page. But of course I switched to extended one (latest) - and it works too.

WebP encoding was introduced to the extended edition in the version following v0.82.1 — v0.83.0.

In v0.82.1 (standard or extended) it just falls back to a default – JPEG. That’s why you were “able to generate page.”