Failed to resolve "content" to an archetype template, Ananke theme

I have the following langage config from Ananke theme:

    title = "Ananke"
    weight = 2
    contentDir = "content/en"
    # languageDirection = 'rtl' for Right-To-Left languages
    title = "Ananke Fr"
    weight = 1
    contentDir = "content/fr"

When I type hugo new content fr/posts/ I get failed to resolve "content" to an archetype template. I get the error no matter what path I give.

But it works if I just provide a path.

Nop, I’m following that tutorial.

I get the same error with:
hugo new content content/fr/posts/

content is the problem.

I am unable to reproduce the problem:

I started with this empty directory structure:

├── en/
└── fr/

Then I entered these commands:


I’ve added ananke with the git submodule command. Could this be a problem?

The ananke theme seems to be working fine.

No. That’s exactly what I did.

hugo new site quickstart
cd quickstart
git init
git submodule add themes/ananke
echo "theme = 'ananke'" >> hugo.toml

Then I copied/pasted your language configuration into hugo.toml.


mkdir content/{en,fr}
hugo new content content/en/posts/
hugo new content content/fr/posts/

No problems. Tested with hugo v0.126.1.

Which version are you running?

hugo v0.111.3+extended linux/amd64 BuildDate=2023-03-16T08:41:31Z VendorInfo=debian:0.111.3-1

Seems like I’m runint the wrong version. I’ve installed with debian, is it outdated? Should I install with Nix?

See minimum version requirement listed in the quick start guide:


Linux installation methods are described here:

Ok, that should solve it. Thanks a lot

Ok, it works now. I’ve downloaded the .deb from hugo releases.


For Ananke theme, pick the extended version of Hugo.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.