Error on site render: bare keys cannot contain '\x00'

Newbie here, I’m trying to render my first site. Of course I had to get creative with the quickstart tutorial and use a different theme. I get the following error on the hugo command:

Error: “C:\Hugo\Sites\blog_archive\config.toml:1:1”: unmarshal failed: Near line 0 (last key parsed ‘’): bare keys cannot contain ‘\x00’

Not sure what is up, the error doesn’t line up exactly with similar issues and questions I’ve been able to find here on the forums? As far as I can tell, there are no rogue NULL characters in my config file (see below) — especially not “near line 0”, which I assume would be the first line of code.

Any help is appreciated, not just to solving the issue, but to hopefully understand what is going on…


baseURL = “
footnoteReturnLinkContents = “:leftwards_arrow_with_hook:
title = “title”

theme = “minimo”
copyright = “”

Paginate = 5
preserveTaxonomyNames = true

enableRobotsTXT = true

enableEmoji = true

AuthorName = “name”
Subtitle = “subtitle”

description = “description”
title404 = “title”

favicon = “favicon.ico”
gopher = “”

prefix = “”
holder = “name”
startYear = “year”
suffix = “”

dateFormat = “2006-01-02”
listDateFormat = “2006, Jan 02”
archiveDateFormat = “January 02”
hideEntryNavigation = [“page”]
hideEntryMeta = [“page”]
showReadingTime = true
showLastmod = true
taxonomyCloudShuffle = false
accentColor = “#F47A55
hideMainMenu = true
rtl = false

enable = true

header = [“breadcrumbs”]
homepage = [“recent_posts”]
sidebar = [“about”,“search”,“sidebar_menu”,“taxonomy_cloud”]

titleSeparator = “|”

enable = false

client = “fuse”

category = “categories”
series = “series”
tag = “tags”

posts = “/:slug”

Try entering any of the following HTML entity/unicode in the above parameter:


It seems that the config does not accept emoji.

If this does not solve the error then you will need to share a repo with your project.

1 Like

Thanks for your reply! I suspected that one before, and tried substituting it with ↩ to no avail. Neither of your other suggestions work, nor does just commenting out the line or deleting the unicode character.

The project is set up locally, but I can definitely throw have just thrown it in a repo to share:

The TOML is perfectly valid and the emoji is not the problem.

However it seems that something is wrong with this file, since 0x00 = NULL

I just copied the contents of the config to a new file and overwrote the original and then I was able to execute hugo server.

What is your operating system and what editor are you using?

So, a simple copy/paste/overwrite did the trick?

I’m on Windows 10, using Geany. I would be sorry if the editor was to blame somehow!

Not familiar with Geany but please try another editor.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.