Difference in Local Host Version & Netlify Github Version

Hi everyone, I am making my first website and it looks beautiful on my LocalHost version but when I publish it to Netlify it looks poorly formatted and many of the features don’t work (like image resizing and image stacking.)

Here is my Netlify website hosting: https://inquisitive-melomakarona-fb2da5.netlify.app/
Here is my github: GitHub - NabojeetD/KhushiPortfolio: The Repository built to host the wonderful Khushi's amazing portfolio.

  1. what you were doing or what you tried – So far I have tried to be as barebones as I can with my website content and I am using the Eternity template modifying it only slightly.
  2. what you expected – I expected it to look just like how it does on my local host version. The eternity theme page has a link to a great model website & I have forked their github for the theme.
  3. what actually happened. The “enter the site” loading page looks good but the rest of the page is incorrectly formatted.

I have read some other posts on this forum saying it may be a CSS issue, I am trying to override the theme’s font and use the font Georgia. Another post on the forum said this about a similar issue: “Hermit’s theme documentation clearly states that if one intends to make changes to theme’s default CSS, then can do so, but they will have to copy the modified files to the website’s root directory (keeping the same relative path) Because that CSS there can override theme’s default CSS. I did that and the problem is fixed.” May this be my issue? And how can I implement a fix?
Another post said to add “draft: false” to all of the posts just in case they are drafts but that is also not the case.

Massive thanks for any and all help!

Try to add baseURL in config file. If https://inquisitive-melomakarona-fb2da5.netlify.app is your site URL then
baseURL: "https://inquisitive-melomakarona-fb2da5.netlify.app"

1 Like

Wow this worked! Thank you so much!!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.