CSS not working on deployed side via github, on localhost it does work


I’m currently working on a side for my seminar.
I’m new to git, I’m new to hugo and I’m new to all the other stuff around hugo.
I’ve got a side that is working completely fine on my localhost. If I try to deploy it via git, there are no pictures and no css.
The link to the git repository is: GitHub - Nendia/ARVR
(hopefully it’s the right link)

I have installed hugo-extended, i have done ‘npm install’ in my root folder of the side. I have tried some of the previously posted solutions. Two people tried to fix the error, but all of us are failing, because we just know to little about hugo and tailwinds.

At the moment (commit: 3d868d1) the side works, but doesn’t show css or pictures.
I’m using blist as theme in my project.

Hopefully I haven’t forgotten something important and you can help me. I’m currently in despair…

You are serving your site from a subdirectory. Open your browser’s dev tools and look at the console:

Could you help me to understand what I should do?
It’s the first time with subdirectorys and I tried to follow the tutorial there:

What does it mean, that I’m serving my site from a subdirectory? (thx for the tip with the console in the dev tools, we all didn’t look there…)


The subdir is ARVR, Dev Tools shows that the server is looking for


instead of


Oh! Thank you! Okay I’m gonna try to fix this. If it works then, thank you so much!
(If not, I’m gonna reply again.)

Okay, I thought the error must be the line: baseurl = ‘https ://Nendia.github.io/ARVR’ in my config.toml, but it isn’t…
Do you have another tip where I could look?

Okay, now the pictures work. But CSS still isn’t working and I haven’t found the position in the files where the reference is set for the fonts.

Just search your source for woff. Hint: CSS


Okay so I fixed the problems with pictures an the errors in the log.

But still, CSS isn’t working.
This is how it looks like deployed: Blog: Interaktion in Virtuellen und Augmentierten Welten
And on localhost it looks like it should:

Or am I wrong and it is another problem and not CSS?

It looks like you are just changing things, hoping that something will work.

contentDir = "/ARVR/content/de" #Deutsch


I changed this, because I thought (now I’m not sure anymore) that this is the path to my content. And the path to the content was “/ARVR/content/de”
After the change the pictures started to load.
And yes, I’m finally at the point trying everything my friend tells me, because it may work…
I’m trying to make this work since 3 days or something like that and I can’t find a solution.
So yes, sometimes i change things to try them…

No, the path to your content, from the root of your project directory, is:

Oh, yeah… been working on this problem for days now and everything I tried become one mush…

So, at the moment my friend tries things…
Thank you for your help with the paths.
Do you have any more clue where the problem can be?

Fixed it (propably) by copying the layouts folder from the example site