Css not recompiling

I’m trying to get my css changes to show up in the final public site directory. I’m changing the Tale theme.

I’ve tried deleting the public directory before running “hugo”, modifying both the post.scss and the tale.scss[hash-looking thing].content

Nothing has worked; when I check the only css file in the public directory, after everything’s been recompiled, it’s as if my changes had never been made. The css file seems to “persist” through recompilings.

How do I make my changes actually show up in the recompile?

(I cannot share a repo of the code, nor do I know enough about the problem to reproduce it.)

Nevermind, I got it working.
Here’s what happened:

  1. CSS wasn’t compiling because I was using .scss files (from the Tale theme), and Hugo wasn’t the “extended” release.
  2. I downloaded the latest “extended” Windows x64 version, but that hugo.exe was cursed for some reason. (“Access is denied”, folder permission resetting itself no matter what, admin actions not working).
  3. Got a slightly older “extended” Windows x64 version, worked perfectly fine, .scss compile to .css, my changes showed up.

TLDR: the latest extended version of Hugo (Windows 10, x64) was cursed in permissions for some reason. Other versions of Hugo worked perfectly fine.

1 Like

“Do you have the extended Hugo version installed” is the “did you reboot your computer” of Hugo :smiley:

@pkollitsch will extended merge back - so there is only 1 version?

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.