Accessing data from data files causing strange error

I’m following the directions in the “Data” documentation, and I receive the following error on my template:

ERROR: 2015/09/14 Error while rendering page post/post/second.md: reflect: call of reflect

I have the following content in content/data/User0123.yml

Name: User0123
"Short Description": "He is a **jolly good** fellow."
Achievements:
  - "Can create a Key, Value list from Data File"
  - "Learns Hugo"
  - "Reads documentation"

In the template I use the following code:

<div>Short Description of {{.Site.Data.User0123.Name}}: <p>{{ index .Site.Data.User0123 "Short Description" | markdownify }}</p></div>

Just tested this example and it works for me. Which means it must be something environmental (OS?) or something totally unrelated.

Hmm. Could be unrelated. OS is Yosemite. Tried this on another Yosemite Mac and get the same error when running hugo --verbose

FWIW, here’s a link to the code. It’s really bare bones right now, so I suspect I’m missing something simple.

It’s definitely something squirrley in my code. I tried this with a non-custom theme and it works fine.

OK, this was a total user error. I had the data directory in the wrong location. Doh!

@mattstratton Have you figured out how to swap Short Description for a variable such as .Title?

Update, @bep gave us the answer here https://discuss.gohugo.io/t/get-variable-in-order-to-access-named-values-in-datafile/2701