[Windows] local server not stopped


I’m testing with v0.53 in Windows 7 (on Git bash).

Suppose I run ‘hugo server’ and press ‘Ctrl+C’ to stop the server. After that, when I re-run ‘hugo server’, it says ‘port 1313 already in use, attempint to use an available port’.

Is this expected behavior in the latest build or some kind of an issue? I have not experienced this in earlier version (v0.38 as far as I can remember).

Please answer the questions above, or at least guide how to stop the local server.

Maybe the shell or some intermediatery program is catching the Ctrl+C and terminating instead, posting the output of the command maybe helpful.

To kill the server you can use task manager and find hugo.exe and kill it… alternatively in command prompt use taskkill \im hugo.exe \f (not sure if the command is correct)

Thank you for your answer.

It maybe indeed the shell that intercepts the keystroke. When I tested on CMD or Powershell, the process is terminated properly.

My pleasure, good to know that you have solved your issue. Try to use Git Bash only for git as it has some complications with native Windows command-line programs :slight_smile: