Unable to change Universal logo and setting encoding to portuguese (pt-br)


First of all it is important to say that I’m new Hugo user and I have been working in the financial and consulting field as in the academic area as well.

I’m using the Universal Theme (by devcows) and for “n” times (unsuccess) I have tried setting up my personal logo and a new encoding (portuguese).

Is there someone how could help me with some ideas, tips or any help to solve my problem?

I do not want change for another site generator (ex.: Jekly), so I insist to solve this problem.

Tks a lot!



Olá, Andre! :slight_smile:

You need to change the language and logo variables on config.toml:

languageCode = "pt-br"
# Site language. Available translations in the theme's `/i18n` directory.
defaultContentLanguage = "pt-br" 
logo = "img/logo.png"

But for customizing the dates, you need to read the docs: https://gohugo.io/content-management/multilingual/#customize-dates

In the example, I used “pt-br” because there’s already a pt-br.yaml file on the i18n folder. You need pt-PT, you’ll need to create another file.

1 Like

Hi Sergio!

I have already done this but without any effects in my template. I was reading and maybe there is a possible reason in the “lookup order”, but till this moment I could not solve this issue.

Tks for sharing your time!


Soon, I will share my code (probably in the GitHub - my RStudio is working after I have clicked the “Build site bottom”.


You must enable the defaultContentLanguage variable. And also, the logo URL is relative to the static folder, so you don’t need anything else but img/as_partners.png

Tks Sergio!

It worked! :wink: For you, maybe it is a small effort. For me, as a newbie it was solve a lot of hours thinking how could a setting this issue! Let’s for the next step!



1 Like