Theme not rendering correclty

Hello all!
I’m using the the theme hugo-tania, and it’s rendering “I’m” like the first image showing. Also, it’s not applying the “em” tag properly, and it’s showing kikethe second image instead. Can you help me solve these issues?

لقطة شاشة من 2022-02-06 20-09-03

لقطة شاشة من 2022-02-06 20-10-21


You are more likely to receive a prompt and accurate response if you post a link to the public repository for your project.


Let us see your code

Include a link to the source code repository of your project, because we really need the context of seeing your templates and partials to be able to help you. It is trivial to do a quick git clone on your repo, then run hugo server in your project, to help you out. On the other hand, recreating your code from screenshots, or sort of guessing at it, is not.

If you can’t share your repository for whatever reason, consider creating a dummy repo that you can share, which reproduces the problem you’re experiencing.

Thanks! I added a repo.

The tania theme is not present, nor is it a submodule. Our expectation, when trying to reproduce an issue, is that something like this will just work:

git clone --recurse-submodules
cd blog
hugo server

You are right, I fixed it. It’s present now

I can now build your site. On which page will I see the problem?

You can view it on the Welcome to my blog page,

that part “I think you also should have your blog to speak your mind, and reach awesome people around the globe”

it shows em and em, and not applying the emphasize effect, this is the problem



{{ .Text }}

Should be this:

{{ .Text | safeHTML }}

Please take this up with the theme author:

Maybe you can point them to the documentation, which has a specific example:

1 Like

I tried it and it worked! Thanks!
Also, regarding the other issue was, I had to set typographer to false to render the apstrophe correctly, as if I type I’m, it used to show like the following image
لقطة شاشة من 2022-02-06 20-09-03

where could that be solved, or it’s ok to disable typographer in config.toml?

You can keep the Goldmark Typographer extension enabled. It revealed the underlying problem; it did not cause it.

Thanks a lot. you saved my blog <3

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.