[SOLVED] Site no longer builds with version 0.32+ (theme-hugo-foundation6)

I have a site, originally built with version 0.27, I think and with the theme-hugo-foundation6 theme. It has worked fine, with some enhancements, up until version 0.32 and later when the site build no longer works correctly. I have left off posting here in the hope that something would appear that would help, but I haven’t seen anything. None of the docs on page bundles that I have found suggest that this is mandatory, it appears to require extra configuration.

Site built with 0.32.3

                   | EN
  Pages            | 73
  Paginator pages  |  0
  Non-page files   |  0
  Static files     | 59
  Processed images |  0
  Aliases          |  1
  Sitemaps         |  1
  Cleaned          |  0

Total in 386 ms
Watching for changes in D:\Hugo\github.io\blog\{content,data,layouts,static,themes}
Serving pages from memory
Running in Fast Render Mode. For full rebuilds on change: hugo server --disableFastRender
Web Server is available at http://localhost:1313/blog/ (bind address
Press Ctrl+C to stop

Build output 0.32.3

Started building sites ...

Built site for language en:
0 draft content
0 future content
0 expired content
69 regular pages created
12 other pages created
0 non-page files copied
41 paginator pages created
3 categories created
total in 358 ms
Watching for changes in D:\Hugo\github.io\blog\{data,content,layouts,themes,static}
Serving pages from memory
Running in Fast Render Mode. For full rebuilds on change: hugo server --disableFastRender
Web Server is available at (bind address
Press Ctrl+C to stop

Build output 0.31

Are there configuration options to revert to previous behaviour? What have I missed that is breaking my site?

I am only allowed one image per post, so here is the site built with version 0.31.

You need to share the source of your Hugo project. Like a link to your repository.

Only then can someone from this forum see what’s wrong.

Ok, the site repository is https://github.com/billthefarmer/blog. the site is in the blog folder.

At first glance the index.md under /content/ is converting everything into a page bundle. Rename it to _index.md check if that fixes your problem and tell us.

Since Hugo 0.32+
index.md ---> Page Bundle (leaf bundle)
_index.md ---> Section or Nested Section (branch bundle - this can be a bundle also for img resources)

1 Like

Thank you. I have renamed it to site-index.md as renaming it to _index.md fixes the problem, but no site index. This works correctly on both 0.31 and 0.32+.

I was having the same problem and have been looking for this answer for a while. Thanks!

When building all themes to see how they would look on my site, following the process freezes when trying to process foundation6. There are two reasons as I understand -bing a noob- : It tries to load theme-hugo-foundation, while the the showMe page points to theme-hugo-foundation-BLOG and you can look at it. You can however NOT download it and get a 404… The same is true with theme-hugo-foundation (without the ‘-blog’). Since I am a noob as mentioned before I don’t know how to exclude the non-existing themes (the process may do that with a warning, but continuing to process those that exist).

Next, since the process freezes, it never completes. Looking at the directories that allegedly processed successfully, the respective folders exist, are however completely empty. There are however complete (as I believe) directory trees under the ./themes/.git/modules/[theme-name] subfolder. I read a bit and understand that those are isolated modules that can be shared with other modules.

That may be intended and work well (possible lack of understanding on my side), but I did not get to a successful completion as the download/integrate from git stalls processing the non-existent ‘theme-hugo-foundation’.

I hope the att’d collection of screenshots will show.
[Uploading: foundation6missing.jpg…]

It did not. Here a link to the jpg: https://drive.google.com/file/d/1P_0byS-qcDeAiWI0NaSg6RJaVfy5vAz8/view?usp=sharing

It seems that the Hugo Foundation 6 Theme has been removed from GitHub.

Thank you for reporting it. I will see that it is removed from the Hugo website.

Thanks @Guenter_Strubinsky for your repost. The theme has been removed (see https://github.com/gohugoio/hugoThemes/issues/458).