[SOLVED] Chaotic routing Bugs | S3 + Route53 + Forestry … Turns me MAD!


Hi everyone !

I’m becoming totally MAD !
Sorry for this request… but I’ve tried everything and some really strange things are happening since I’ve taken my domain redirection.

My website URLs look to change so randomly, and I don’t know why.
http://www.ledesertenville.com (route53 redirection)
http://www.ledesertenville.com.s3-website.eu-west-2.amazonaws.com/ (my s3 bucket)
(I’m using Forestry service to generate the website from my Bitbucket repo to my bucket)

Question list :

  • Why does the index.html path make the /css root bug whereas the root path work ?
  • Why when I try to naviguate through my website, sometime it goes to my bucket, sometime css does’nt work…?

Best example is :
http://www.ledesertenville.com/voyageurs/ <- Doesn’t work
http://www.ledesertenville.com/voyageurs/index.html <- Works
http://www.ledesertenville.com/about/ <- Works

I’m trying all the RelURL | Canonify | UglyURL combinations since 2 days… It’s why I’m asking you
There is my -> REPO

Many Many Many thank’s… we are supposed to release this website on Saturday, and since I’ve taken my redirection, nothing works as expected…


I hope you get help, but in case no one has this same problem, you might want to check somewhere they deal with AWS or routing issues. You can check your S3 bucket to see if all the files are created properly, but it doesn’t sound like Hugo is your issue here.


It looks to be working really well now.
Is it Possible that the complete route process takes time… more than 36h ?