Probleme with hugo gen chromastyles

Unfortunately I am sure of it.

@McFly Please post a photograph of your keyboard.

1 Like

This is a standard French AZERTY keyboard.

The > in this command:

hugo gen chromastyles --style monokai > foo.txt

is the “greater than” symbol, ASCII 62. I am not familiar with the AZERTY keyboard layout. Do any of the keys map to this ASCII value?

I ask because you said you type this:

hugo gen chromastyles --style=monokailight > assets/css/syntaxcssessai.css

But when you pasted from the console it showed this (no greater than symbol):

anthony@McFly:~/Documents/hugo_with_staticcms$ hugo gen chromastyles --style=monokailight assets/css/syntaxcssessai.css
1 Like

It looks like the “greater than” symbol, ASCII 62 that jmooring metioned is the shifted version of the key to the left of the W in the keyboard pictured in the photo. That is you should press the shift key while pressing the < (less than) key.

Assuming of course your system has is configured to use the layout that matches the labels on the keys. If not, you may want to check:

How to fix wrong layout for AZERTY keyboards - Ask Ubuntu

or something like it for your Linux distribution.

Thanks for your reply but it’s same problem and my > touch is good. i continue to search.

Very thanks

What does

echo "Testing\nredirection to file" | tee >testingredirection.txt

output on the terminal, and what appears in the file testingredirection.txt ?

What shell are you using? Something other than bash? What Linux distribution?

Oh, and what is the output of:

hugo version

How do you install Hugo? Is it a snap, or self-built, the .deb, or a GitHub release binary that you download, for instance?

What environment are you running in? (i.e. container, virtual machine, bare metal, an install of Linux you did yourself, one managed by a school or workplace, or what?

Is it e.g. a stock Ubuntu install, or a Linux From Scratch, or somewhere in between?

In short, there is something different about your environment or Hugo binary that is at play here (assuming of course that this isn’t an annoying ‘game’).

The file is well created, it’s good news

anthony@McFly:~/Documents/hugo_with_staticcms$ hugo version
hugo v0.111.2-4164f8fef9d71f50ef3962897e319ab6219a1dad+extended linux/amd64 BuildDate=2023-03-05T12:32:20Z VendorInfo=snap:0.111.2

Hugo is snap install

I tried with Codium and Default shell of Ubuntu

Classic install on Linux Ubuntu

Thanks for your help

I’d recommend trying an install method other than the snap. In the past the snap packaging has had issues, and it looks like that may be true again. @jmooring seems to have some knowledge of the snap issues, so maybe he can provide more insight on that.

In any event, I’d recommend installing from a GitHub release and putting the hugo binary somewhere that is already in your PATH or putting the binary somewhere that you add to the PATH. If that works, then it’s clearly an issue with the snap packaging.

/snap/bin/hugo version

hugo v0.111.2-4164f8fef9d71f50ef3962897e319ab6219a1dad+extended linux/amd64 BuildDate=2023-03-05T12:32:20Z VendorInfo=snap:0.111.2



rm -f foo.css
/snap/bin/hugo gen chromastyles --style monokai > foo.css
head foo.css

/* Background / .bg { color: #f8f8f2; background-color: #272822; }
PreWrapper / .chroma { color: #f8f8f2; background-color: #272822; }
Other / .chroma .x { }
Error / .chroma .err { color: #960050; background-color: #1e0010 }
CodeLine / .chroma .cl { }
LineLink / .chroma .lnlinks { outline: none; text-decoration: none; color: inherit }
LineTableTD / .chroma .lntd { vertical-align: top; padding: 0; margin: 0; border: 0; }
LineTable / .chroma .lntable { border-spacing: 0; padding: 0; margin: 0; border: 0; }
LineHighlight / .chroma .hl { background-color: #ffffcc }
LineNumbersTable */ .chroma .lnt { white-space: pre; -webkit-user-select: none; user-select: none; margin-right: 0.4em; padding: 0 0.4em 0 0.4em;color: #7f7f7f }

Thanks Joe, sorry for pinging you then.

I wonder though, if @McFly is using an encrypted directory (e.g. eCryptfs home dir, which mounts via fuse, and I’m not sure how that interacts with snaps), or is otherwise mounting a dir on or under /home that the snap does not like.

@McFly what output does the following command show:

df -h

Hi thanks

Command result

anthony@McFly:~/Documents/hugo_with_staticcms$ df -h
Sys. de fichiers Taille Utilisé Dispo Uti% Monté sur
tmpfs              764M    2,1M  762M   1% /run
/dev/sda2          219G    102G  106G  50% /
tmpfs              3,8G    144M  3,6G   4% /dev/shm
tmpfs              5,0M    4,0K  5,0M   1% /run/lock
/dev/sda1          511M    6,1M  505M   2% /boot/efi
tmpfs              764M    4,3M  760M   1% /run/user/1000

With command on the shell i have the foo.css file is write

After your different answers, I think that it is codium (1.76 installed via snap) which is at fault, because in the terminal it worked.

So there remains only Codium.

I must not have tested the right command, by dint of testing in all directions, we get lost.

Anyway, thanks to you frjo jmooring cshoredaniel because I think you have found the problem.

Great thanks

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.