Problem running Hugo off shared network drive?

For development reasons, I have my Hugo source files saved on a shared network drive. Up till now, I’ve had no trouble running the “hugo server” command off of the drive using the windows drive location, i.e. “hugo server -s S:\Website\Source”

However, lately, when I run it, though it says it created the site, it never runs the server. The last thing I see is “Watching for changes…” It doesn’t even do that, though, not refreshing when I do make changes.

It seems to do this even when I run with the --renderToDisk=true flag.

I wonder if this is an issue with my using a shared network drive, because when I manually copied the contents of that folder to my C:\ drive and ran the same command there, it worked fine. I did try a symlink to the network drive, but that didn’t make a difference.

Any idea about how I could get this functioning like it used to? I’d really like to continue using the shared drive, but as it is now, I have to manually regenerate the site after every tiny CSS change. Very inconvenient…


I believe this to be a limitation with the file watcher we use. The Docker people are seeing the same thing:

Ok, thanks for the quick response! I look forward to seeing it resolved eventually.

In the meantime, I’m using a 3rd party app to sync one-way from my shared folder to another on my local HD, then running Hugo on that local folder. I’m using the software described here:

You can maybe try to run Hugo on your network device - if it’s not only a hard drive at your router.

It should be possible to run Hugo server with watching options on most NAS-systems.

Thanks for the suggestion! Unfortunately, it’s on a server I don’t have access to other than the specific shared directory. That said, I’m happy with the stopgap solution I’ve found. I make changes on the shared drive, it’s synced immediately to the local directory, and Hugo right away compiles and serves the changes.