PDF gives 404 on site deployed

Hello!

this question is simular to this post on here but they dont come to any conlusion there.

On my site I have a link to my pdf file like so:

<a href="/mypdf.pdf" download>mypdf</a>

My pdf is located in my static folder.

Heres the issue, when i run my server locally, my link works and I can download the file.
BUT when i deploy my site to surge.sh, it doesn’t appear there.

I run these commands when i deploy:

hugo
surge public\ 

after hugo my public structure looks like this:

project
`-- public
    |-- css
    |-- js
    |-- img
    |-- 404.html
    |-- index.html
    |-- mypdf.pdf
    |-- index.xml
    `-- sitemap.xml

Ive tried ctrl+f5 on the site, so refreshing it a dozen times, re did the hugo process, tried fiddling with the link path.
Other files like images seem to work fine.

what else could i try?

I’m not using surge.sh, but after googling, “surge sh dont accept pdf”.

I found these,
https://github.com/sintaxi/surge/issues/302#issuecomment-520579997,
https://github.com/sintaxi/surge/issues/257#issuecomment-419558021

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.