No website found when using Github Pages

I am trying to publish my site using Github pages.

My main Repository is : GitHub - Iron-Shark/IronShark-Blog: IronShark-Blog
This holds all of my site files, including.

The blowfish theme as a submodule


My public sub-dir as a submodulet : GitHub - Iron-Shark/

I am trying to use this method, becuase I have zero expirence with github actions.
Github says the site is publishing successfully but when I go iron-shark it only show a page not found screen.

The right way to do this is with GitHub actions. They make it very easy, even providing a default workflow tailored to Hugo sites.

OK. So I set up the repo GitHub - Iron-Shark/ for github actions, and it is still not working.

I followed the steps found here : Host on GitHub | Hugo

I also had to change these settings to the workflows to run successfully.

Documentation didn’t mention this at all, from what I saw. Not sure if this is actually needed or correct.

And I still end up with a “successfully built” site that only show a 404 error.

When I visit I see this:

Thanks for letting me know. Apparently my browser was redirecting me to my custom domain automatically when I tried to go to the address, and since I hadn’t set up the cname file yet I was getting the error. Its working now.

Thanks for the help.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.