Multi-language adds language to static URL unexpectedly


I’m using Vex-Hugo and have enabled the Arabic language.

Then I duplicated the products and renamed it as articles.

Under English the images are showing correctly. But when I switch to Arabic the images disappear.
The reason is that it is looking for the images under /ar/. I don’t know why this is done this way, while the products that I originally copied from doesn’t do that. There must be a setting that I can’t find.

The actual image tag shows like this on source page on the browser:
<img class="img-fluid" src="images/post-img/unblock-youtube-small.jpg">

The image isn’t showing though. And when I click on the image link, it can’t load it and shows the path as:

But the statics shouldn’t have ar in front of it. How can I change this behaviour?

Many Thanks,

What is the value of your baseURL configuration in config.toml? It looks like the image src needs a / in the beginning.

Yes, that was it. Thank you.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.