Mermaid "mindmap" diagrams not working. Version problem?

Hello, all

I’ve been integrating Mermaid diagrams into my Hugo site for some time just by adding the code between ``` blocks. I don’t recall ever having to configure anything for this to work. It just did.

However, now I’d like to render a Mermaid “mindmap” diagram and I’m getting a “syntax error in graph mermaid 8.8.3” message. I suspect it’s because I need a later version of Mermaid but, I can’t figure out how to update it.

i.e. I don’t recall ever configuring anything to make it work in the first place, so there’s no where to go to say “use the latest version”, etc.

I’ve read plenty of articles about how to make Mermaid work in the first place, but since it’s already working somehow, I’m hesitant to go fiddling around for fear of breaking whatever magic is making it work today.

Thanks for any help you can give.

Which theme are you using?

Thanks for replying!

I’m using “Academic.”

You do.

You are more likely to receive an accurate and timely response from the Hugo Blox team:
https://github.com/HugoBlox/hugo-blox-builder/discussions

They also have an active Discord channel:
https://discord.com/invite/z8wNYzb

Done. Thanks.

FYI… I suspect that using their Discord channel might be the fastest way to get a response.