Inconsistent output on builds


#1

Hi there,

I am slicing different types of pages onto a single list. Sometimes on builds, I see 2 different renderings of my data and it’s hard to reproduce. It seems to happen at random. I am on version 0.42.2 and tried different loops (changing Site to Data, etc.) but no luck. Here are the 2 ways the code will render…

(DESIRED) - All assets in one list


UNDESIRED - “split by folder” view


Clicking on a box above then opens a second page with that asset type


This is my code:

frontmatter will have different types and different resource label (the folder grouping seems to happen sometimes on resource label - “Product info”)

post.md
image


list.html


summary.html

Any help would be truly appreciated! @rdwatters tagging you in case you have the answer (you usually do!)


#2

Heya, most times folks posting screenshots of code aren’t going to get the help they need. In order to reproduce the issue, we need to build the site ourselves, so that means sharing the project code.

If you can’t or don’t want to, make a smaller project with only the templates and content required, and share that. :slight_smile:


#3

thanks, i was hoping maybe there was a glaring issue that could be seen :sweat_smile:


#4

If you want to make nice and crisp shots of your code: https://github.com/mixn/carbon-now-cli/


#5

Resources is on the predefined front matter list and it is used for Page Bundles.

I suppose that you are getting inconsistent behavior because you call resources as a parameter to render a slice of your pages.

Also see related topic over here:

May I suggest that you try renaming resources to something else. Even resource should do.


#6

Oh wow! I had no idea! I’ll try that. Thanks!!


#7

I renamed resources and so far I haven’t hit that issue! I am carefully optimistic, especially because of the page bundle logic tied to Resources (very specific behavior). Thanks again @onedrawingperday!