I am unable to process SCSS with Hugo extended

Hugo Version = hugo v0.104.3-58b824581360148f2d91f5cc83f69bd22c1aa331+extended linux/amd64 BuildDate=2022-10-04T14:25:23Z VendorInfo=gohugoio

My setup:


Not sure what I’m doing wrong. I have the files in the assets folder and I believe I am calling them correctly.

Type tree assets and paste the results.

Also, change this:

{{ $style = $sass | resources.ToCSS $options }}

To this:

{{ $style := $sass | resources.ToCSS $options }}

Your paths looks correct (re. the screenshot), which makes me guess that you somehow have your asset folder isn’t mounted.

/assets is the default, but if you have a mounts section in your config file, you need to be explicit about all of them, see

That worked, I didn’t realize that piece of configuration around modules. Thank you all so much

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.