Hugo Server does not render site

When I use hugo server i get a blank page at http://localhost:1313. I have have the themes installed and I’m using the hyde theme defined in my config.toml as theme="hyde".Also I have a content being built called It is not set to draft as well.

The easiest is of course if you have your project public at GitHub to test.

If not:

  • output of hugo version
  • output of screen when doing hugo server

A tip could also be to have a look at /public and the index.html in there to verify that it’s empty.

Okay I tested it here in my office and hugo server is working now. Hopefully it will work on my laptop too. I had to move my project outside of my Google Drive so I didn’t get the annoying desktop.ini. Is that the only way to deal with that. I tried shutting it off to no avail.

Also I can’t upload my themes folder to github because it has git files in it. Why is that? When I deleted them before it prevented me from doing any further commits and I has to start over.

I found this article. However when I tried to git push it gave me another error permission to spf13/hugoThemes.git denied to zachdyer. :frowning:

Is this what I need to do?


There are plenty of good resources out there for Git and Git submodules. I suggest read some.

For your case I would

  1. Remove themes
  2. Do a git add submodule themes/hyde

The above totally from head and untested.

It errored fatal: pathspec 'submodule' did not match any files

as I said, from head and totally untested …


git submodule add ...

It says must be absolute path.