Hugo port

is there a way to set the hugo’s port ? I’m using an nginx http proxy in front of hugo, but the URLs are http://myhugosite:1313/

hugo server -p 1234

sorry I mean I don’t want that all URLs contains the port, is there an option to hide ?

Set nginx to use port 80?

already done, but like you can see here : all URLs use domain.tld:1313/ instead of domain.tld/page/cv/
it seems URLs have been generated with hugo in all statics files

Set --appendPort=false


great exacly what I need, anyway this options does not appear with --help

You need to type ‘help server’ to see the server specific settings.

indeed, great